Troubleshooting

This topic explains the troubleshooting tips that will help you to resolve problems that you encounter during Windows installation of Kony MobileFabric Integration Service . The error messages displayed during the installation are stored in log files.

Following are the installation scenarios and the troubleshooting tips.

Adding Proxy Details for Tomcat Multi-node Environment

Error message

When you try to access a server console using a loadbalancer URL and port number, the system displays the error message "Unable to connect" for the Tomcat multi-node environment.

Cause

When aserver is installed on Tomcat, the https port is configured as a proxy port. the Tomcat multi-node environment, the proxy port is a loadbalancer port. When you try accessing the server console with a loadbalancer URL and the port number, the proxy port number of any other node is added to the loadbalancer URL instead of the given loadbalancer's port number.

Workaround

To add the proxy details in the server.xml file to the Tomcat multi-node environment, follow these steps

  1. Go to the Tomcat multi-node install folder.

    For example: <Server_Install_Folder>/tomcat/instance1/conf.

  2. Open the server.xml file.
  3. In the server.xml file, search for proxyPort="${https_port}" and replace it with proxy name="<frontend_loadbalancer_URL>" proxyPort="<port number of the loadbalancer>".
  4. Save the server.xml file.
  5. Restart the Tomcat server.

Note: The preceding changes should be performed in the server.xml files of all Tomcat nodes of servers (Middleware) systems.

Installing Tomcat as Windows Service

To troubleshoot installing Tomcat as Windows service, follow these steps, :

  1. From the Start menu, open Control Panel and double-click Administrative Tools > Local Security Policy. The Local Security Policy window appears.
  2. Expand Local Policies > User Rights Assignment and double-click Log on as a service.

  3. From the Log on as a service Properties window, click Add User or Group and enter the user name.

  4. Click Check Names. The user gets added. Click OK and then Apply to close Log as a service Properties window.
  5. Select the policy Act as part of the operating system and perform the steps 3 and 4 and click OK and then Apply.

  6. From the Start menu, open Control Panel and double-click Administrative Tools > Services. The Services window appears. Locate Apache Tomcat 6 and double-click it.

  7. Click on Log On tab and select This account option.
  8. Enter the username, password, and Confirm password. Click Apply and OK.
  9. Right-click on the Apache Tomcat 6 and click Start to start the Tomcat service.

Note: In case you are unable to start the service after following the above steps, provide full control to the user for the KonyServer folders including sub-folders and start the Tomcat service again.

Copyright © 2013 Kony, Inc. All rights reserved.